Cruise Control - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
GT-Rich's Avatar
Join Date: Feb 2008
Location: Surrey
Posts: 154

Member car:


Re: Cruise Control

I use my cruise all the time and can confirm the following.

1). when you first turn the inginition on you should see the cruise control green indicator light come on for a second and then go off again. I seem to remember it being at about the 4 o'clock position on the rev counter.

2) it only seems to work in 4th, 5th and 6th

3) if your foot is even only slightly on the clutch or brake it wont engage

4) it you intend to use the cruise on your journey you need to turn the on/off ring to the on position, this will then be indicated by the cruise control green light.

5) once you are at the speed you need to flick the +/- switch to the + position for just a second, and this will engage the cruise at this speed.

6) if you touch the clutch or brake, even only slightly it will dis-engage the cruise (but not turn it off)

7) to re-engage just press the button on the end of the stalk and it will take you back to the speed it was last set at.

8) with the cruise engaged you can adjust your speed up and down using the +/- ring

9) if you turn off the ignition the last speed setting will be lost, but the cruise will still be switched on (as indicated by the light) once you start up and get going again, refer to point 5

The technician is wrong and probably doesn't even drive an Alfa with cruise.

Hope this also helps.


Character is what you have left when you've lost everything you can lose.

GT-Rich is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , cruise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome