Rear Wiper Fix- a big Thanks! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-05-08 Thread Starter
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso

Thumbs Up Rear Wiper Fix- a big Thanks!

Just booked my car in next FRiday for 5 year/50k service by phone and said to Wyn there appear to be no issues...........!
Started it this morning in reverse, rear wiper came on and stopped after an inch. Thought 'B8gger new motor required' but did a search when I got home and SamlCampbell's "How to fix the motor" was just the ticket.
Water gettting down the shaft had corroded it so it was just a case of removing motor, disconnecting, removing circlip and case cover then driving out main shaft.
Once cleaned with fine w&d and re-greased, all back together and everything OK!
How I love this site!
lovelyred159 is offline  
Sponsored Links
Status: Tentatively treading
AO Platinum Member
Hamster's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Gloucestershire
Posts: 15,686
Images: 34
Re: Rear Wiper Fix- a big Thanks!

Great stuff. Just shows what a pool of knowledge we have here

Glad you fixed your bella
Hamster is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

big , fix , rear , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome