Total electrical failure, then all fine again! Ideas? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Total electrical failure, then all fine again! Ideas?

Okay, there I was, sitting in co-op car park. Just got back in, plipped the car, all the doors unlocked, the selespeed motors triggered, put the key in the ignition, waited like a good boy for all the motors to finish whirring, turned the key, everything died! Everything! radio, dash, lights, locks, boot light, instruments, central locking - everything. Took key out, still dead.

Popped the bonnet, pocked some wires, wiggled some pipes, nothing. Slammed the bonnet, nothing. Opened it again called a mate with a set of booster cables, I thought the battery had just died!

Mate arrived, tried the same things again, car started fine, ran fine, battery shows 14.4 charging, 12.7 off!

Mate is still laughing at me muttering "F@@@ing italian junk, buy a decent reliable motor for f@@@s sake"

Any ideas?

Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
Re: Total electrical failure, then all fine again! Ideas?

Had a similar thing on milady's 156....just before I went for the battery replacement route I tried the earth cable to the gearbox....minute degree of movement...everything OK.....5 seconds work with a 13mm spanner and job sorted.

Of course it could be something completely different - the god of electricity possibly wasn't Italian.....
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , failure , fine , ideas , total

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome