Engine control sytem failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-05-08 Thread Starter
Status: -
Join Date: May 2008
Posts: 2

Member car:

Alfa 156 1.9 Jtd

Hmmm Engine control sytem failure

I am driving a 156 jtd 2004 model, and have enjoyed all four years of ownership. Only had one small problem with a replacement gear selector after 24,000 miles (dealer said lack of use) normal Italian fuel gauge vagness.

Problem which has just cropped up is the motor control system failure warning has come on is this a common problem with other jtd owners or is it Alfa's electrical gremlins, have done some research woundered if it could be the MAF unit could be dirty?

Hope some one can shed some light on this matter

Coupe Deville
Coupe Deville is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Engine control sytem failure


moved to 156 lounge
classicgal93 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , engine , failure , sytem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome