2 Related Problems? Idle speed / Fan - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 14-05-08 Thread Starter
Status: -
AO Member
ianc's Avatar
Join Date: Nov 2007
Location: Liverpool
Posts: 42

Member car:

156 2.4JTD

2 Related Problems? Idle speed / Fan

Hi, I noticed 2 faults on my JTD today. Firstly when stopping at lights etc the idle speed does not always return to the 600rpm sometimes it stays about 1000rpm then at the next lights it will go back to 600rpm?

The second thing that I have discovered today regards the electric fans. The temp reading as always been about 70degrees but today when stuck in traffic it got to about 90. When I got home I thought I would test to see if the fans were coming on so I left the car running on the drive. The temp got to just over 90 and one of the two fans came on but at the same time the engine revved upto about 2000rpm on its own until the fan cut out and then went back to normal idle speed?

Any ideas would be appreciated. Should only one fan come?


156 2.4JTD Diesel - Rock 'n' Roll
ianc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fan , idle , problems , related , speed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome