Loose brakelight? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 14-05-08 Thread Starter
Status: -
AO Silver Member
Join Date: Mar 2007
Location: Heathrow, UK
Posts: 1,365
Loose brakelight?

of all the random things i've heard this is new to me, my bulbs seem to blow in pairs - never on the same fuse but the brake light will go and a week later a bulb in the front will go!
So, I changed the headlight quite easily after spending a week being terrified of it, only took 20mins all in and no cuts/grazes! 19 of those minutes was trying to unclip the bulb!

anyway, the problem: i changed the brake light but the next day the dash was lighting up again, after some swearing and opening the housing up, the new bulp looked and worked fine, but once put together its not working! it is somehow not getting a proper connection when all back together.
please share any advice as the only thing i can think of is putting some foil in, but that could short or melt or something bad so not a clever idea.

thanks all
mo 156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brakelight , loose

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome