ABS activating too soon - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-05-08 Thread Starter
Status: -
AO Member
Join Date: Jan 2006
Location: Ireland
County: Dublin
Posts: 53
ABS activating too soon

The ABS on my 156 1999 2.0L is activating unnecessarily. When applying brakes at slow speeds and going over a slight bump the ABS triggers. Also when driving on an open road at speed even applying the brakes lightly activates the ABS. This happens 9 times out of 10. This started happening a few months ago and has gradually become worse. I have no dashboard warning lights showing and I have new tyres and new pads, the disks have been checked and are fine.
Any advise on what it could be?
DubiousDude is offline  
Sponsored Links
Status: Making Ron Jeremy look small !
AO Platinum Member
howell811's Avatar
Join Date: Mar 2007
Location: Virgin Islands (British)
County: -
Posts: 26,529

Member car:


Re: ABS activating too soon

Might be the caliper, had it on the wife's car. Garage called it a 'grabby caliper'. replaced it and it's fine.
howell811 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , activating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome