NAV-CD stuck in ConnectNAV+ - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 06-05-08 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 18

Member car:

Alfa 147

NAV-CD stuck in ConnectNAV+

Hello again,

Having discovered this helpful site, I thought I'd post my other, albeit, niggling problem with my Alfa and hope against hope that someone has a FREE solution to it

My Navteq CD is stuck in the system and the eject button doesn't seem to do anything apart from showing a "CD error" display message on screen. This message goes off when I turn the system off and on again. Got the damn system primarily because I commute frequently between Belgium and the UK and now I can't drive to the UK simply because I can't change the CD

I've done a search online on this problem and none of the solutions seem to work. Someone did suggest giving the console a good punch...I did...hand still hurts...CD is still stuck.

Any other solutions before the garage takes the system apart and charge me an arm and a leg?
MsSteel is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

connectnav , navcd , stuck

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome