Still no torque ! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-04-08 Thread Starter
Status: -
AO Member
Mr Bacchus's Avatar
Join Date: Apr 2008
County: -
Posts: 462
Still no torque !

Couple of questions to help me troubleshoot my 'zero torque below 2500rpm problem'. Car is a Gt 1.9 diesel.

If I can move the shaft of the vnt vacuum actuator freely (with pliers) is that proof that the turbo vanes are not stuck ?

The exhaust gas smells real bad, not the smell we are all used to but really stinks (hard to describe a smell). Any idea what this could be and would it be related to my problem ?

Where would be the cheapest place to purchase a maf ?

This problem is damn frustrating and the spend is creeping up.

Mr Bacchus is offline  
Sponsored Links
Status: -
AO Platinum Member
Roswell's Avatar
Join Date: Mar 2004
Location: United Kingdom
County: Durham
Posts: 33,630
Images: 15
Re: Still no torque !

Call Justin @ BMC on 01325 300520, he should be able to help you out.
Roswell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome