Turning the key twice? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-04-08 Thread Starter
Status: -
AO Member
sirocco's Avatar
Join Date: Jul 2006
Location: Australia
Posts: 781
Images: 16
Turning the key twice?

While starting my 147 over the past few days, and intermittently that is, as I turn the key to start - there would be nothing other than a 'click' sound (although all the electrics start up as they normally would). However when I remove the key and turn it a second time, it starts totally as per normal. I'm assuming an electrical/wiring fault, but then again I don't really know what I'm talking about...

Any ideas???


EDIT: Should also mention that the odometer flashes after the car is started on the second attempt. This continues until the car is restarted.

Last edited by sirocco; 19-04-08 at 14:20.
sirocco is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Turning the key twice?

Possibly the starter motor sticking, click might be the solenoid throwing.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

key , turning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome