Opinion Needed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 12-04-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Posts: 18

Member car:


Opinion Needed

I Have A 2001 147 Silly Speed

100,000 Miles

The Silly Speed Jus Went

I Got A Quote Of 1800 For The Actulator , Pump And Relay

I Dont NO Weather To Fix It Or Move On

Any Ideas Where I Can Get The Parts For Cheaper

Or Second Hand Parts

If I Dont Fix It I Will Sell Car For About 6-700 Pounds
OKENEMEM is offline  
Sponsored Links
Status: -
Join Date: Apr 2008
Posts: 4
Re: Opinion Needed

I look for a heavy damage car around salvage yards and use it for parts. Who knows what goes next - it's an Alfa or couse- A Light Fires Alfa - ALFA.
javnas is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,620
Re: Opinion Needed

Try and find another Selespeed in a scrap yard or on eBay and pinch the actuator off it..
Pud237 is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: Opinion Needed

What exactly happened?
Smaky is offline  
(Post Link) post #5 of 5 Old 13-04-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Posts: 18

Member car:


Re: Opinion Needed

I Was Driving It And I Got The Slespeed Error Come Up On The Dash Board

I Had Neva Seen It B4 And I Wasnt It The Place Or Position To Look Into It

So The Next Day I Had To Go Some Where I Took It About 8 Miles And The Warnin Came On Again

Then All Of A Sudden The Error Came Up Again And The Car Went Into Neutral And I Cudnt Change Gear

Im Jus Gonna Buy Another Car And Let My Baby Sit In The Garage For A While Till I Can Get Her Sorted

Wat A Shame

I Feel Like I Didnt Get Enough Warning
OKENEMEM is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

needed , opinion

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome