Engine management system - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-04-08 Thread Starter
Status: -
Join Date: Apr 2008
Posts: 1
Engine management system

Dear all,

first post to this forum, please help a newby!

For the past few days I've noticed that the car seems to stutter when I'm doing about 35mph in 3rd gear, revving about 2500.

Anyway, the engine management warning light came, and stayed active on my 156 diesel multijet yesterday on the way to work. The car wouldn't rev above 3000 but I still got to work OK. On the way back, the light didn't come on and everything seemed fine.

Light is back on today, similar symptoms to yesterday.

Reading this forum, it seems like the MAF is faulty. Does anyone have any advice on a) how to confirm if it is the MAF and b) any recommendations for garages in the Warrington / North West England area?

Best Regards
joem156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , management , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome