156 Issues! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-03-08 Thread Starter
Status: -
Join Date: Feb 2008
Posts: 9

Member car:

156 2.0 TS

156 Issues!

I have had my 1999 TS 156 for a little over a month and have a few issues, hoping some people can help.

My MAF was replaced after some initial problems, it seemed to run fine for about a week now it doesn't seem to be pulling as it should, particularly in the early gears. Sometimes when starting I can floor it in first and it takes and age to get going. I have disconnected the MAF and it makes no difference.

My front heaters, those which demist the front windscreen don't appear to be blowing any air out, all the others seem fine and blow warm and cold. Any ideas what this could be?

The back offside brake light is not working, all other lights seem fine, however the blown bulb warning light is on constantly when my lights are one, could this be related to the dashboard?

The lid on my airfilter has lost a bolt or 2, any suggestions on sourcing a second hand one or perhaps repairing this one?

On top of these niggles I also need to get the front suspension arms replaced before MOT in August, and the radiator could do with replacing before the warm weather starts.

Looking like it could be an expensive few months!
DaveWright is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: 156 Issues!

Re the bulb warning light, check the numberplate bulbs.

Re heater, it is usually the moving flap below the upper cover.
The duct behind the radio gets distorted and stops the flap moving.
Usually a sharp knife trimming the edge of the flap sorts the problem.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome