Motor Control System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 6
Help Motor Control System Failure


Hi all,

I know this has been mentioned before, but I need to give a bit of background first!

Initially I had a fault with the MAF causing no acceleration & black smoke, this was replaced 2 weeks ago. The MCSF light came back on within 20 miles or so & stayed on. Back the car went to be reset, this time it had poor air quality! Car had the air filter replaced & pipes checked for any splits etc. Again the MCSF light came on not long after reset. I had a service at WAD in Wolverhampton on Friday(by the way these are very helpful), again they reset & checked the airbox & cleaned up the EGR. The car now seems to be running fine after WAD serviced & cleaned the EGR - but the MCSF light is on AGAIN! I've tried the reset procedures stated on the forum, but still the light comes on - please Help!
northernman is offline  
Sponsored Links
Status: -
Awaiting Email Conf
Chill's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Lake District
Posts: 1,773
Images: 26
Re: Motor Control System Failure

When WAD plug in their examiner - what fault code is displayed?
Chill is offline  
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Motor Control System Failure

reset what? the light goes off by itself when you fix the fault, there's no need to reset anything.

as above, what fault code(s) were retrieved?
jug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motor , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome