Ignition jamming 147 JTDm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-03-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Posts: 11

Member car:

Alfa 147

Ignition jamming 147 JTDm


I have a 2005 147 JTD 16 valve and have recently had an occasional problem when starting it. I turn the key part-way and wait for the glow plug light to go out but sometimes when I then go to start the engine the key won't turn any further. I've tried moving the steering wheel in case the lock is on but that doesn't free it. The only way to move it is to turn the key back to the original position. The key doesn't appear to be damaged at all.

What is this likely to be? And could it have any relation to the occasional MCSF light that comes on which on diagnostics points to an error between phase and rpm sensors?

Any suggestions would be very welcome - it's a fantastic car apart from these minor niggles
AmandaT is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
Re: Ignition jamming 147 JTDm

Right, I had this on my 156 JTD, never got to the end of it and why it happens, but the way I got around it when I wanted to use the glow plugs was to turn the key past 'MAR' and then hold the key there, just at the point where it clicks off all the electrics besides the glow plugs, then when the glow plug light went off I would only need to move it a very short distance to engage the starter.

I did this for two years with no problems, I don't think its anything to do with the MCSF failure or a potential key problem..

Autolusso Penrith - UK's leading independent Alfa Romeo specialist with branches in Bedfordshire, Cumbria & Dorset

Wizard Exhaust systems available here

Tel: 01768 879 171
Pud237 is offline  
(Post Link) post #3 of 3 Old 30-03-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Posts: 11

Member car:

Alfa 147

Re: Ignition jamming 147 JTDm

Okay thanks, I'll try that.

Anyone else had this problem?
AmandaT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , ignition , jamming , jtdm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome