4 months in with my 159 now 13500 miles! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-03-08 Thread Starter
Status: -
AO Member
Join Date: Nov 2007
Posts: 203

Member car:

159 2.4 JTDm S/W

4 months in with my 159 now 13500 miles!

The promised update. Firstly and overall - high mileage driving has never been this fun!

Problems discovered:

Auto wipers (see my earlier posts) : great if its raining, rubbish with spray or light drizzle.

Sat Nav: keeps turning of motorway to go a long slow route! very odd. No post code searching - crass!

Windscreen in rain: the wipers collect rain at the bottom of the screen and there seems to be no drain so the water is pushed back up the screen the pasender hap of the glass is ALWAYS dirty
MPG : overall i am on 31.5 ( auto 2.4 jtdm) if i drive slowly i get perhaps 1 more - not worth it!

Body: metal is too thin, many stone DENTS on the bonet already. Doors become heavy and jam

Experience: the road holding is unbeliavable! fast round bends with so much less roll than the old Audi - I could never go back!

nigelboyle is offline  
Sponsored Links
Status: So good I did it twice
AO Silver Member
PC7671's Avatar
Join Date: Mar 2007
Location: A4074
Posts: 2,063
Images: 15
Re: 4 months in with my 159 now 13500 miles!

Good to hear your enjoying it.
PC7671 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

159 , miles , months

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome