147 Selespeed Wont Start! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-03-08 Thread Starter
Status: -
Join Date: May 2007
Posts: 3

Member car:

Alfa 147

147 Selespeed Wont Start!

Hi all

Ive had my selespeed 147 for best part of a year now. And only recently it has randomly failed to start. After trying and leaving it for about 20 mins it eventually does start.

However the problem has worsened and now, like today for example, while moving in traffic, the engine cut out. Again it wouldnt start but eventually did after 20 mins of trying!

I took it down to my local garage only yesterday and they ran it on one of their computers with no faults coming back.

It last had a service 6 months ago with all new spark plugs and filters put in.

Any ideas?
jaso77 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 147 Selespeed Wont Start!

Tryusing the search function for crank sensor, see if these other threads are similar to yuor problem.
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: 147 Selespeed Wont Start!

What Harry Tsg'er said.:
zulu ferret is offline  
(Post Link) post #4 of 4 Old 24-04-08 Thread Starter
Status: -
Join Date: May 2007
Posts: 3

Member car:

Alfa 147

Re: 147 Selespeed Wont Start!

Just to update;

I read what you guys said, and what other people said who were experiencing the same sort of problem, and bang on you was right.

I took in into local garage, got the Crankshaft sensor changed, and the coolant temperature one just in case, and car been running fine ever since.

Thanks a lot guys just thought I would update to help others who get the same problem.
jaso77 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , selespeed , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome