Please help annoying niggles - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-03-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 48

Member car:

147 2.0 ts lusso

Please help annoying niggles

hey everyone, I had problems with the vdc and abs lights on my 147 2.0 ts, had the battery changed and they disappered for about two weeks however today they've come on again (the battery brand new), also i've got a minor oil leak, from the engine bottom does anyone know what it could be and is it serious?????
akouzo is offline  
Sponsored Links
Status: -
Join Date: Mar 2008
Posts: 3

Member car:

Alfa 147

Re: Please help annoying niggles

ive had similar problems. not the oil leak but the vdc and abs systems problem. had it back to the dealer a few times and theyve done a few things. changed a chip, replaced connectors etc etc. hasnt helped tp be honest. its intermittenant and goes away in a couple of days so ive been lazy even though the car is still covered by warranty. seems to be quite a common problem. just realised this wont have helped at all but at least u know ur not alone!
marcharris29 is offline  
Status: -
AO Member
emranvalera's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Leicestershire
Posts: 398
Images: 8
Re: Please help annoying niggles

The one thing you can do is open the bonnet and unplug the main socket which is situated at the top right as if your looking at the engine and see if the is any moisture in there. You will get the a error code unless you know someone who can clear the codes. I had the same problem and i was advised to look at this as my battery is more or less brand new. I took the plug out and it a few contacts where wet so i cleaned them with electrical spray pluged it back in and it was fine, and cuz i have alfadiag i cleared the codes.
emranvalera is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

annoying , niggles

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome