Buying a second hand Alfa GT - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 22-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 2

Member car:


Help Buying a second hand Alfa GT

Hi to all

I am currently in the process of buying a 2005 Alfa GT JTD .

Everything checks out fine on the car except one thing. The first time I switched on the car two of the error lights came on. The onboard computer notified me about an ABS and VCD failure, never the less we took the car for a test drive. 10 minutes later when we took the car out for a second time all the error mesages were gone (without any intervention from the dealer)! After reviewing the service record we noted that this problem existed on the car from the first service (20000km).

Should I be concerned?

Has anyone else had this problem before? The dealer said its an electronic problem that can be solved easily by resetting the computer (some how I doubt it since it has been a problem for almost 3 years now and has been reset several times ).

Any advice or warnings to a prospective buyer?
dnavid is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Buying a second hand Alfa GT

Hello and welcome.: ECU fault? Need those diagnostic 'gurus' for a definitive answer I guess.?:
zulu ferret is offline  
(Post Link) post #3 of 5 Old 22-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 2

Member car:


Re: Buying a second hand Alfa GT

Some how I dont think its an ECU problem. I think (or hope) that its a sensor issue and not an actual ABS or VCD failure
dnavid is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Buying a second hand Alfa GT

Welcome to AO

Moved to GT Lounge
BigFoot is offline  
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

Re: Buying a second hand Alfa GT

not uncommon. it usually suggests a power supply fault to the VDC/ECU. in some cars, this has been implicated to one of the MIDI fuses in the housing atop the battery's POS terminal.

see my pic (taken for other purposes). fuse in question is the dark blue MIDI one. replacing this fixes problems i'm referring to, but i can't be certain it's what caused the fault you experienced:

note, mine is a V6, and similar probs i've read about are with GTA's. so it could be different in a JTD, including the fuse layout. but if that fuse exists, you could have the dealer replace it with a new one.

i recall i had the error too when i first had the car (day 1), but it has not recurred. so perhaps it relates to the VDC/ECU resetting itself after having sat in a dealer largely unused for a prolonged period.

GT . 3.2 . Q2 . Kyalami Black - Red . Eibach . KONI . ASSO . ATP 19" . TAROX . FERODO . Mille Miglia exhaust
155 . 2.0 8V TS . Grigio Grey - Grey . H&R coilover . Enkei 17" . TAROX . GOODRIDGE . REMUS
75 . 3.0 . Alfa Red - Grey
shiny_car is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , buying , hand

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome