I've Snapped 156's Hand Brake Cable @$^&#! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
I've Snapped 156's Hand Brake Cable @$^&#!

Hi, Just parked up and pulled my hand brake on and...twang...it's gone!

Totally loose lever and no braking of wheels.

Phoned local garages, and they can't get cables from suppliers cos they're all closed for easter...Doh.

How much should I expect to pay for a new cable and fitting etc...

eg..how much should I not spend this afternoon drowning my sorrows and whilst wearing my cider visor...(similar to beer goggles)

Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
Re: I've Snapped 156's Hand Brake Cable @$^&#!

Not a big problem - the cables aren't expensive, and its not a big job to do.

If you are desperate to do the job over the weekend, I've got some second-hand cables over the hill, near Burnley.....

07976 384980 if I can help....

rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , @$and# , brake , cable , hand , snapped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome