156 fault codes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 18-03-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2006
Posts: 75

Member car:


156 fault codes

Hi. I've a 2001 156 2.4jtd, a while ago the ABS and handbrake warning lights came on on the dashboard. According to the manual this means there's a problem with the EBD system on the car, and following the 48,000 mile service the mechanic said that fault codes 05 and 017 had shown on the diagnostic machine. These apparently relate to the relay in the ABS unit and a problem with the ECU (not sure which way round).
The anti-lock brakes do not work (the car skidded when made to on wet roads) and the lights are on continually.
Has anyone experienced a similar problem? - any help would be appreciated as I've a feeling this could be expensive to fix.....
valda is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , codes , fault

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome