Airflow Massmeter replaced, but Monitor control fault back on again! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 6
Airflow Massmeter replaced, but Monitor control fault back on again!

Hi all,

Last week I had severe power loss in my 2005 147 JTD M-jet, resulting in black smoke on attempting acceleration! A 'diesel doctor' came out in the Stafford area(vey helpful & reasonably priced) & cleared the 'airflow sensor fault' on the ECU - meanwhile replacing the Airflow mass meter. The car now starts but was still kicking out black smoke on acceleration - car was accelerating with slight hesitancy. The Monitor control message is back on with the amber Engine light. I started the car up this morning & again the message/slight hesitancy in acceleration. I have since taken the car on the motorway to obtain more speed/acceleration & she seems to be okay now - with no obvious black smoke!

Is it possible their was still a lot of old fuel deposits from driving home from Oldham to Stafford while faulty? & that although the airflow mass meter was replaced/Computer reset could still cause slightly rough running yesterday & cause the monitor fault to come back on?
northernman is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,618
Re: Airflow Massmeter replaced, but Monitor control fault back on again!

Not sure really.. Give it a few more days of driving and see if it cures itself. Thats what I'd do
Pud237 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

airflow , back , control , fault , massmeter , monitor , replaced

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome