rear washer jets - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-03-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 48

Member car:

147 2.0 ts lusso

rear washer jets

Hey everyone!!! got a problem with my rear screen wash jet, the hose attached to the wiper intailly came loose however I managed to fix that and theres water coming through the jet . The only problem is its got very little pressure but I can't seem to find the block. The front water pump works fine and the front jets have loads of pressure help!!!
akouzo is offline  
Sponsored Links
Status: No longer-Desperately SeekingGiulia
AO Member
Sir Baloney's Avatar
Join Date: Jan 2005
Location: Lancashire
Posts: 232
Re: rear washer jets

Hi and Good Evening!
When our 147 2.0 was new we had no rear wash.The cause was that the pipe running past the LH suspension turret was trapped when the bonnet was closed.I pulled out the lump of sound deadening foam by the turret,reformed the squashed pipe by rolling it between finger and thumb and re-routed it where it wouldn't be crushed-foam back and water was delivered.Dreadful PDI though, on an £18000 car ......
Sir Baloney is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jets , rear , washer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome