Temperature Gauge - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-03-08 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 4

Member car:


Temperature Gauge

Over the last week or so my temperature gauge has been playing up, when i first start up the car and start driving for about 5 minutes, the gauge is showing normal temp 90, then it will drop back down as if the engine is still warming up, then this morning on driving to work, the gauge then went all the way up to 130, i got the beeping warning light saying the engine coolant had reached max temp, then after about 5 minutes of continual driving it went back down to normal, any ideas??
mattcarter is offline  
Sponsored Links
Status: -
AO Silver Member
Mr-T's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Durham
Posts: 1,415

Member car:

Citroen DS3

Re: Temperature Gauge

Had exactly the same problem with my first Brera. Sounds like the same thing.

It was the temperature sensor in the sump that was faulty and had to be replaced.

The car was perfectly safe to drive though.
Mr-T is offline  
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Temperature Gauge

going up to 90 then dropping back down is normal, it happens when the thermostat opens, after that the thermostat should open and close to keep the temp in its operating range, but yours is overheating, which suggests that your rad is not losing heat effectively.

the rad fan shouldnt be needed this time of year, however when your enigne overheated the fan should have come on to help it lose heat, if your fan didnt work then you also need to fix that.
jug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gauge , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome