147 jtd mjet smoking loss of power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Location: dorset
Posts: 7
Cry Like A Baby 147 jtd mjet smoking loss of power

hi people,thx for letting me on your forum,hav a bit of an issue with my 06 mjet 150,the dealer is either struggling or useless!!!
I really hope someone can help me
Bought this car in january,had a few issues but mainly sorted out,appart from xs smoke under partial to full acceleration,and flat under 2000 rpm,but not all the time
took it back to meridian again! and they could not easily ind any thing wrong,saying maf sensor ok,turbo pipes ok,they suspect egr maybe,possibly but on back order,gave me car back but now undrivable,no power no power turbo loads of power,makes getting round,round abouts interesting
there issue is i am a,mitsubishi master tech and it is not a mitsubishi
so they will do it there way
cheers danny
mastech is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , jtd , loss , mjet , power , smoking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome