still overheating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 02-03-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 12
Hmmm still overheating

156 1.8 .have replaced water pump and checked thermostat and its working ok but still overheating after short drive,anyone got any ideas??
johname is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2001
Location: uk
Posts: 82

Member car:

alfa gtv 2.4 jtd

Re: still overheating

you need a new rad
jayson is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: still overheating

Is it overheating on the move or while stationary or both.

In addition to checking the rad, check the fan too.
David C is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: still overheating

Could possibly be a blocked rad, or a dodgy temp sender, maybe a dodgy guage. Tmp senders normally under-read though but I have sen them go the other way.

Easiest thing to do though is pull the radiator and blast water through itin the opposite direction, that should force out any crud that's gathered in there, you could also make up som hoses to connect tto the engine to flush that backwards too, hopefully forcing out any crap that may be lurking in there too.

Has it ben losing water lately as well? That could indicate a failing head gasket.
Smaky is offline  
(Post Link) post #5 of 6 Old 03-03-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 12
Re: still overheating

The car starts to overheat after about 10 minutes on the move,will check rad and fan as suggested.cheers John
johname is offline  
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,567
Images: 13
Re: still overheating

I would check the rad first. It could also be the waterpump, or a thermostast that is stuck in the closed position. However thermostats almost always fail in the open position as they are designed to.
Are the hoses going in to the radiator hot when the car is overheating, if not the stat could be stuck shut.

It may also be possible to see if the water pump is pumping if you remove the expansion tank top (ideally when cold) and looking to see if the coolant is swirling as you rev the engine. The coolant is fed back to the tank from the upper small hose and you may be able to see coolant going back in if the pump is ok.

symon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome