Help!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-03-08 Thread Starter
Status: saving for a 3200GT
AO Member
midlifecrisis's Avatar
Join Date: Aug 2007
Location: United Kingdom
County: Swansea
Posts: 895
Help Help!!

Ive got my first MOT on Saturday and i cant get the rear seat back to lock back in place. Its the smaller part of the rear seat back which wont lock back. The big seat back locks no problem. I think the mechanism might be faulty but has anyone on here experienced this sort of problem with their seats.
midlifecrisis is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Help!!

May sound silly, but have you tried giving it a REALLY hard shove back into place? I mean, like really hard? I often have it on cars where it won't simply snap back into the catch, you gotta give it a very hard push and shove in order for it to latch back into place.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome