creaking clutch in 147 1.6 TS Lusso - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-03-08 Thread Starter
Status: Fingers crossed
AO Member
Join Date: May 2007
Location: United Kingdom
County: Hampshire
Posts: 355

Member car:

Brera 2.2 S

creaking clutch in 147 1.6 TS Lusso

Last few days a creak has developed in the clutch pedal of my 147 1.6 TS Lusso, it is absolutely doing my head in and is rather embarrassing. It can even be heard from outside the car if I am stopped at lights. I'm a little concerned about just spraying WD40 down there, but is this even likely to solve the problem?

Service due in a couple of months, are they likely to deal with this kind of thing as part of the service? I will probably go up to the Alfa Workshop in Royston.

Any thoughts appreciated.
jamezm is offline  
Sponsored Links
Status: Slumming it
AO Silver Member
MPH's Avatar
Join Date: Oct 2006
Location: Tokelau
County: Nukunonu
Posts: 5,551
Re: creaking clutch in 147 1.6 TS Lusso

Have a look in this thread. Should help you guide some grease round those pedals!
MPH is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , clutch , creaking , lusso

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome