156 jtd 16vmj - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-03-08 Thread Starter
Status: -
Join Date: May 2006
Posts: 4
156 jtd 16vmj


My 56k jtd has just developed a wheezing sound when accelarating, although no loss of power. I recently had a new clutch fitted. Is it possibly a simple lose nut on the exhaust or something more sinister like the turbo. Its going in on Wednesday, i would just like some ideas.
cwh is offline  
Sponsored Links
Status: -
AO Member
Vespasian's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Norfolk
Posts: 528
Re: 156 jtd 16vmj

I noticed quite some time ago my turbo sounded different, slowly but surely, the turbo whine got progressively worse until you could hear the turbo giving up the ghost, last thursday, it gave up completely, Hope thats not what you have got
Vespasian is offline  
Status: -
AO Silver Member
Join Date: Sep 2007
Location: United Kingdom
County: Derbyshire
Posts: 1,613

Member car:

159 Ti

Re: 156 jtd 16vmj

possibly the lower boost pipe which chafes on a bolt when it expands with boost.
Could just be a very small hole at the mo, not big enough to cause smoke.
jasons is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 16vmj , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome