156 2.0 TS 98 cut out HELP!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-02-08 Thread Starter
Status: -
Join Date: Mar 2007
Posts: 3

Member car:

Alfa Romeo 156

156 2.0 TS 98 cut out HELP!!!

Hello my crazy Alfa friends, had some bad news this morning just got home!
My Alfa 156 2.0 TS decided to die on me whilst i was crusing along at about 40mph....
Just before cutting out i started losing power rapidly, it started juddering and felt like it was missing, and i noticed the little red injector light came on, there was a slight backfire, and then i slowly came to a standstill on the side of the road.
I tried restarting it i had full electrics and it was turning over but the engine would not catch/spark just electrical ignition noise....
I waited but still no go i had only been driving for about 5 mins...
The car has a good service history im always checking the oil etc just coming up to 68,000mls.
Im crossing my fingers and hoping its not the cambelt as i dont thing its been changed!!!
I took the cambelt cover off when the loader got us home and the belt seems to be fine it doesnt look like it has snapped but it feels a little slack i can almost pull it off the gear teeth (almost),.
The variator is noisy on start up (was)
I didnt hear any large bangs or noises but the engine was kind of buzzing before it cut out like and electrical noise but then i suppose from inside it could well have been a mechanical noise?
Car has been lovely up until this CAN ANYONE HELP ME?
turk147gta is offline  
Sponsored Links
Status: Redlining
AO Member
ALRN's Avatar
Join Date: Jan 2007
County: -
Posts: 862
Images: 12

Member car:

Brera S

Re: 156 2.0 TS 98 cut out HELP!!!

Hope it's not but it does sound ominously like the timing belt.Hopefully somebody with more technical know-how will be along shortly to help.If not try posting this in the 156 lounge (tech area)
ALRN is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: 156 2.0 TS 98 cut out HELP!!!

Hi welcome to AO.

Moved to 156 lounge
classicgal93 is offline  
Status: Always working
Identity Confirmed
Authorised Trader
Autolusso's Avatar
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 6,242
Images: 222
Re: 156 2.0 TS 98 cut out HELP!!!

Sounds like you killed it, won’t be cheap, good luck any way.

If we can help we will

By the way hello and welome

Autolusso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , cut

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome