Oil level warning - 156 1.9 JTD - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-02-08 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Posts: 14
Images: 1

Member car:

156 jtd

Oil level warning - 156 1.9 JTD


Had my alfa since new year, i had a strange one this morning with it (although has happened before). I started the car up and the check activated, the oil level check reported that the engine was empty, so i turned off and started again (when this happened before i did that and it cleared).
It took 5 starts and stops to finally clear and for the check to report the engine was full. did get out of the car and check after the second time this came on. it is indeed full.

No other warning lights have come on IE low oil pressure etc.

Is there a sensor in the sump that measures the oil level and are these a common fault causing the check to report untrue readings?

primus234 is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,288
Images: 12
Re: Oil level warning - 156 1.9 JTD

Don't have one in my TS but the one in my old 75 always lied ... ended up disconnecting the sensor as it drove me (and the wife) nuts ...
gazza82 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , jtd , level , oil , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome