VCD Failure? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 24-02-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Location: Croydon & Manchester
Posts: 45

Member car:

147 Selespeed

VCD Failure?

Hi everyone

I picked up my new 147 2.0 Selespeed on Fri night...Great car, but a few niggling issues. I got it pretty damn cheap, so can live with/resolve little niggles.

I have the MCSF warning (no other warnings), but everything seems fine with the car. I changed the battery already by the way. ASR works fine, ABS works fine, but I can get her out of shape without the VCD trying to assist. I can only get the light flashing on the dash when the front wheels actually spin. It understeers far more easily than I expected at quite low speeds.

I thought all 147's were fitted with VCD/ESP. It doesn't say it's optional in the owners manual.

Any ideas?



Last edited by bpm147; 25-02-08 at 09:29.
bpm147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , vcd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome