Motor control unit failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-02-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Location: North Devon
Posts: 37
Motor control unit failure

Put this in my introduction b4 realising thats the wrong place. Got the dreaded dashboard warning but unlike many of the threads my car runs perfectly, reasonable mpg, passes it's emission test at mot etc. The independent who services it says there is a fault with 1 or more of the 4 lambda sensors. He clears the warning off with his laptop but it soon comes back on. It's on as soon as you start up & stays on. He tells me that it's not doing any harm & in truth we've probably done 10,000 miles since it started. Does this ring true & where do I find the part numbers for replacements. Alfa oem are about 75 ea, are there any good pattern parts? Any comments on the 15 universal ones on ebay? Thanks in advance Jez
Jez in Devon is offline  
Sponsored Links
Status: Running on fumes
AO Member
rathkennades's Avatar
Join Date: Feb 2007
Location: Dublin, Ireland
Posts: 187

Member car:

MiTo Cloverleaf

Re: Motor control unit failure

the main issue with losing a lambda sensor will be that your engine will probably use more fuel. It may also be slower to pick up. I guess in the long term it's not a good idea to drive with one gone, but for a few weeks I wouldn't worry (well, I'm driving with one out for nearly a month and I'm not so worried!)
There are a few sites offering oem parts cheaper than that, and some other sites offering spurious sensors for about £25.
Couldn't speak to the quality of ebay, but I guess it's about trusting the seller!


rathkennades is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motor , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome