Headlight Despai - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-02-08 Thread Starter
Status: -
Join Date: Jan 2008
Location: Essex
Posts: 1

Member car:

Alfa 156

Headlight Despai

Hi Guys,

I've got a 156 Selespeed and was driving to work the other day and noticed the headlights werent doing a great deal.

Sidelights work, fog lights work, full beam works but no dipped beam.

Changed the fuses, the relay and tried new bulbs but still no luck.

Any ideas?

superadam72 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Headlight Despai

You need to go back to the fuse box with a multimeter and see if you have got voltage going in and coming out. If so then its between the fuse block and the lights..so it could be a connector either not pushed home or corroded contact. If no voltage enterign the fusebox it could be a faulty switch.

It may be a job for an auto electrician. I can only go so far with these things before I become a cheque book mechanic.

Good luck


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

despai , headlight

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome