AFM/MAF - Airflow Meter - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 09-02-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Posts: 13

Member car:

Alfa 156 2.5

AFM/MAF - Airflow Meter

Having problems with my '98 2.5 156.

Starts but then cuts out after a number of seconds, represented itself as a fuel/pump issue but after further investigastion it sounds like the MAF. I read a post about disconnecting the electrical plug to the upright of the air intake. Did this and it made no difference, is there any way I can prove it's the MAF, did I unplug the right wire?

It's def. not the imobiliser as it ran for about 20 seconds one time, although very rough.

On one of the occasions it was running for a few seconds, as soon as I hit the gas it cuts out, another reason to point towards fuelling :-(

Any help would be greatly appreciated.
jscanlan_001 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: AFM/MAF - Airflow Meter

Unplug the MAF sensor, the car should then start and run. It won;t be perfect, but better than with a bad MAF. If that improves things, then replace the MAF, if it soesn't then the prblem is elsewhere!
Status: Loving My 159
AO Member
michaeld's Avatar
Join Date: Sep 2004
Posts: 654
Images: 5
Re: AFM/MAF - Airflow Meter

Check a couple of obvious things first.

Look at the spark plug wells for water/oil.

Look for air leaks........maybe the MAF to throttle body duct.

Is the fuel pump running?

Is it worse when the engine is cold or hot?
michaeld is offline  
Status: -
AO Member
Join Date: Nov 2007
Location: Bradford west yorkshire
Posts: 57
Re: AFM/MAF - Airflow Meter

has the fuel injectors been ruled out??? seems to be giving the symptoms .
Droolingunited is offline  
(Post Link) post #5 of 5 Old 11-02-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Posts: 13

Member car:

Alfa 156 2.5

Re: AFM/MAF - Airflow Meter

OK I got it sorted.

I assumed it wasn't petrol related as I put an extra 1.5 gallon in to make sure. Guess what's coming next.....

The car is parked on my drive which has a slant on it therefore there must have been just enough petrol to allow a tiny bit through at a time, so it showed the symtoms of the MAF.

Once i'd reversed it off the drive using the starter and it was on the flat it purred back into life.

Very odd that it was pulling that tiny bit through, anyone got an explanation or was it just unlucky?

Anyway thanks for the replies and next time the car is low on petrol I will reverse it on the drive!
jscanlan_001 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

afm or maf , airflow , meter

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome