156 buzzing/humming from behind dash on start up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-02-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2008
Posts: 41

Member car:


156 buzzing/humming from behind dash on start up

hi guys!
a newbie here!
i ve just bought a 156 2.5 v6. fantastic car and fantastic engine but every morning when i start it up there is a buzzing/humming noise coming from behind the centre of the dashboard (near where the stereo is).
i ve tried turning the air con compressor off (little button on temp dial) but this makes no difference
the noise is quite loud and lasts for 2 -3 mins
any ideas anyone?
cheers guys
jsolesbury is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: 156 buzzing/humming from behind dash on start up

Hi ya, welcome

Moved to 156 Tech Lounge
BigFoot is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , buzzing or humming , dash , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome