xeon light fault-intermitent!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 04-02-08 Thread Starter
Status: -
Join Date: Oct 2007
Location: gloucestershire
Posts: 5
Chilling xeon light fault-intermitent!!!

I have just purchased a 156 gta 2003 model with the xeon head lights,but the passenger light some times does not come on!!! but if i switch on and off about 3 or 4 time it comes back on!!.
i have looked all through the paper work with the car and have found there was a problem with this light before,and alfa fitted a new bulb,but this could not have been the problem!!.
Spoken to alfa in worcester and they have not got a clue!!!
can any one please advise me of what could be the cause of the passenenger side xeon light not comeing on first time the lights are switched on??????
Also does any one know a good place to get the alloy wheels referbished,as they have kerb marks on and the paint has started to buble up as well????
Many thanks
james............................................. ......:
JAMES RICHARDS is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: xeon light fault-intermitent!!!


Moved to 156 Tech Lounge
BigFoot is offline  
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Northamptonshire
Posts: 224
Re: xeon light fault-intermitent!!!

Sound like the first time the bulbs are being asked to light up there isn't enough voltage going to the bulb. Xenon lights need a lot of voltage to ignite before they settle down to around 35V.
Maybe after a one is lit up it can then generate enough voltage to get the other one up so maybe its something to do with the ballast that supplys several thousand volts to the headlamps to get them to light up.
Dont have that much knowledge of the system or where the ballast is but as it is a high voltage high current operation I would suggest you find a dealer that knows about Xenon before you electricute yourself.
ChrisSound is offline  
(Post Link) post #4 of 4 Old 05-02-08 Thread Starter
Status: -
Join Date: Oct 2007
Location: gloucestershire
Posts: 5
Re: xeon light fault-intermitent!!!

Thanks for the advice
JAMES RICHARDS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

faultintermitent , light , xeon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome