window wiper woes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-02-08 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 3

Member car:


window wiper woes

hi folks, need some help... my wipers are playing up big time and i'm stuck. they work on fast , but not on the other two slower settings !
I think it might be a relay but dont know where they are or which one.

Is there a way to test them when you get them out ?

dooty74 is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,070
Re: window wiper woes

General wisdom is that you can sometimes strip the motor and clean up the excess grease.....but more often than that you have to swap the motor....the control circuitry is built in to it.....

Not an uncommon fault - I must have broken a dozen or more 156s and I've only two wiper motors left.....
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

window , wiper , woes

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome