Temporary fix for 147 selespeed issues? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 31-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 1

Member car:

Alfa 147

Temporary fix for 147 selespeed issues?

Hi all,

I have a 2005 147 selespeed with the dreaded 'stuck in neutral' problem. My mechanic identified a pump+relay failure requiring replacements.

I have a friend who lives about 200km away who's willing to fix it for me, so I can save a fair bit on the mechanic's price.

My question is: how to get it there!? It's such an intermittent problem that I might be lucky and get it there with no issues, but I'm wondering if there's anything I can do to increase the odds that I can get the car there OK without having to fork out for a tow-truck.

Any advice appreciated!
lastgasp is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: Temporary fix for 147 selespeed issues?

If it is the usual pump/relay issue then no there is nothing you can do to make it less likely to fail on a 200km drive.

Your fried could always drive to you or you could fit the new pump yourself.
David C is offline  
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Re: Temporary fix for 147 selespeed issues?

I was having problems with mine -and cured it a couple of times with a tap or wiggle of the pump.....was about to change the pump but listened to advice on here and changed the battery......its actually cured about 95% of the issues......

Might still change the pump, tho.....
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , fix , issues , selespeed , temporary

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome