GT windscreen washers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 24-01-08 Thread Starter
Status: -
AO Member
beckypumps's Avatar
Join Date: Jan 2008
Posts: 27

Member car:


Help GT windscreen washers

I was wondering if anyone has had problems with the rubber hose that connects the jets on the bonnet to the windscreen washer tank/pump.My hose lookes like a tea bag, the car is just under 3 years old. if this hose has go there may be others around the engine bay in a similar condition. I have no manual/drawings of the route the rubber tube takes and am looking for any tips on changing it, also the non return valve in the splitter attached to the underside of the bonnet seems tight, is it ok to remove the spring and small rubber diaphram?and just run the system open ,im assuming its function is to reduce the time water takes to get to the jets (keeps the line primed)
Thanks in advance of any info.
beckypumps is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

washers , windscreen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome