garage trying to rip me off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 22-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 1

Member car:

alfa romeo156

garage trying to rip me off

hi all alfa owners
my alfa failed the mot with problems of emmision , i have an iratic idle problem and also its drinking alot of fuel
i paid the garage 50 pounds for a diagnostics , she said its the maf and i need a new one , if that dont work i then need a new idle valve sensor , any ideas
thanks all
mikalfa is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: garage trying to rip me off

Moved to 156 Tech Lounge
BigFoot is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
Re: garage trying to rip me off

Its common to see MAF failures..

To get a better idea if they are correct, try unplugging your MAF and going for a drive. See if it feels any better, if it does, I'm sure the MAF is kaput.
Pud237 is offline  
Status: -
Club Member
Membro Medio
ALFAPAT's Avatar
Club Member Number: 237
Join Date: Nov 2001
Location: United Kingdom
County: Moray
Posts: 1,862
Images: 6
Re: garage trying to rip me off

Check also your running temperature ,IE: thermostat, it can make the car run rich, if not then Maf and lambda, more likely the former.
ALFAPAT is offline  
Status: - Update
Posts: n/a
Re: garage trying to rip me off

So why do you think the garage may be trying to rip you off.?On the face of it the complete oppposite seems to be the case as the diagnosis they have given you would match the faults you have reported perfectly..and if the diagnosis machine has confirmed the faults....Seems to me like they are just doing the job you asked them to do, or am I missing something here

Status: Ich habe entscheiden.
AO Gold Member
filipharvey's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Norfolk
Posts: 7,207

Member car:


Re: garage trying to rip me off

Sounds like spot on diagnostics to me! More than likely that it is indeed the MAF.

If you are going to get a new MAF, make sure, absolutely 100% that it is a GENUINE BOSCH MAF, others will not work properly, as many of us have found to our cost!
filipharvey is offline  
Status: -
AO Member
Join Date: Aug 2007
Location: United Kingdom
County: Kent
Posts: 526
Images: 10

Member car:

GTV Lusso 3.0

Re: garage trying to rip me off

What engine is in the car?

A faulty Lambda will also cause the dodgy idle and drinking of fuel.

Edit: Missed the part of the diagnostic being done. I don't see how they are trying to rip you off?
m0t is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: garage trying to rip me off

You need the car put on a diagnostic system again and have the IDLE ACTUATOR reset ...

MAF isn't always likely to show up on a diag check unless it is completely dead, but lambda should. To test the MAF yourself, simply disconnect the leads and try it yourself (engine management light will come on, but go off when you plug it back). If it revs free-er, you are looking at a new one (BOSCH!)
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

garage , rip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome