No fault code on my 1.9 jtdm GT! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 14-10-16 Thread Starter
Status: spending too much money on my GTV
AO Member
 
Join Date: Oct 2006
Location: United Kingdom
County: Devon
Posts: 98
No fault code on my 1.9 jtdm GT!

Hi All

I am hoping someone will be able to tell me if this is normal

Every time I start my GT it says on the dash 'faulty glow plug' however when I plug my diagnostic tool in it says there are no fault codes!

Obviously there is something wrong with the glow plugs or their wiring but was hoping to narrow down the problem by looking at an error code.

Thanks in advance

Gazza
GazzaF15her is online now  
Sponsored Links
Advertisement
 
Status: now a diesel head..
AO Silver Member
 
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,583
First check they all in tight enough..if so then it is likely the glow plug control unit.
joeymannero is offline  
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,240
Loads of possible faults cause the Glow Plug Error message to come up... Which depending on what you're using to read the codes might not show up...

Not to worry though, the error code message is pretty useless! Just says there's a problem with the Glow Plug system... So could be fuse, relays, glow plugs, wiring etc....

Got a multi-meter? Quick and easy check to check the resistance between the plug and ground to spot a obviously faulty plug!

Where in Devon are you? I've got 3 spare plugs and a relay module on the spare parts shelf in the garage! Worthwhile doing some fault finding first though... Might be nothing wrong with the kit you've got!

_The_Editor_ is offline  
Status: -
AO Silver Member
 
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,208
My 156 flashes glow plugs with no fault code stored. I've not investigated as it is still a good starter even when cold. If the dash warnings bother you then new glow plugs are pretty cheap and all being well are easily removed with a deep socket (9mm maybe 11mm or 8mm can't remember).
dgmayhead is offline  
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,240
9mm deep socket, a warm engine, and a quick squirt of penetrating oil around each plug... Had mine slide right out
_The_Editor_ is offline  
(Post Link) post #6 of 8 Old 17-10-16 Thread Starter
Status: spending too much money on my GTV
AO Member
 
Join Date: Oct 2006
Location: United Kingdom
County: Devon
Posts: 98
Gonna get a multimeter out and check the glow plugs tonight.
I really hope it is them as I do not fancy chasing relays and wiring around!

Thanks

Gazza
GazzaF15her is online now  
Status: Flaps? What flaps?
AO Silver Member
 
_The_Editor_'s Avatar
 
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,240
The relay is easy enough to swap out... It's the massive black rectangle mounted on the firewall next to the fuel filter!
_The_Editor_ is offline  
(Post Link) post #8 of 8 Old 18-10-16 Thread Starter
Status: spending too much money on my GTV
AO Member
 
Join Date: Oct 2006
Location: United Kingdom
County: Devon
Posts: 98
Yippee all sorted!

Lifted the engine cover, pulled off the glow plug leads set about measuring the glow plug resistance. It soon became evident that glow plug for cylinder No1 was the culprit. Eventually found a deep 9mm socket, warmed the engine up and sprayed penetrating oil everywhere. Braced myself for a fight to get the plug out and yes you guessed it - it was only done up finger tight!!!! Fitted new one any way and now enjoying beep free driving.

Thanks everyone for all their help

Gazza
GazzaF15her is online now  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
code , fault , jtdm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome