Ac compressor probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2016
Location: Italy
County: -
Posts: 3

Member car:

Alfa 147 TS 1.6

Ac compressor probs

Left car garaged for a few weeks and now ac compressor clutch has big problems. Anyone else experienced something similar?
147 ts 2000.
gregc is offline  
Sponsored Links
Advertisement
 
rxe
Status: Busso
AO Silver Member
 
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,636
What's wrong with it?

Not engaging - probably gas pressure issue

Engaging but loads of noise - seized pump or knackered belt?
rxe is offline  
(Post Link) post #3 of 3 Old 17-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2016
Location: Italy
County: -
Posts: 3

Member car:

Alfa 147 TS 1.6

Quote:
Originally Posted by rxe View Post
What's wrong with it?

Not engaging - probably gas pressure issue

Engaging but loads of noise - seized pump or knackered belt?
belt is fine.

there was a burning smell and then I found the ac clutch coil wire broken but not before driving it for a bit first. I am currently changing the coil to see if that is the simple issue and hoping no internal AC parts have burned out.
gregc is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
compressor , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome