Alfa GT window issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2016
County: -
Posts: 2
Alfa GT window issue

Hi Guys,

My name is Vince, I'm from Belgium. I'm new on the forum but I've used it as a source of info for quite some times.

I recently aquired my first Alfa Romeo, a blackline GT JTD.

I was prepared for the well known little Alfa problems, and have experienced my fair share so far.

Today as I closed the drivers side (left one in Belgium door, the window (wich automatically opens a bit when the door opens) didn't close all the way.
I've seen many window-related posts, but none of them were of any help...

The window also seems to open way to much, as it should normally only go down half a centimeter, to allow the door to open. This window opens about 4-5 centimeters... And then, when I close the door, only goes op 2-3cm, leaving a gap.

Also, when the door is open, and I try to close the window using the window up and down buttons, the window will only go half way up, no matter how many times I push, smoothly down, smoothly up, but only half way up... If I then proceed to shut the door, I can fully close the window, it will go well past half way, but the last 5cm require a few pushes to get it fully closed.

I've tried 'resetting' the windows holding the buttons up and down for 10sec, but that didn't seem to work..

Any thoughts? Thanks in advance!

Verstuurd vanaf mijn ONE A2003 met Tapatalk
Vince_alfa is offline  
Sponsored Links
Advertisement
 
Status: now a diesel head..
AO Silver Member
 
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,571
I would start by battery disconnect overnight and then a soft reset when you reconnect.

If this doesn't work sounds lkke you have a faulty WCU on the doof in question.

Easy to replace , have done it on mine....

Twice!
joeymannero is offline  
(Post Link) post #3 of 3 Old 09-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Apr 2016
County: -
Posts: 2
Thanks, I'll give that a try!
Hope the wcu is fine cause I heard they're quite expensive, but we'll see.

Verstuurd vanaf mijn ONE A2003 met Tapatalk
Vince_alfa is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
alfa , issue , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome