Reversing light switch 147 53plate - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 07-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2014
Location: United Kingdom
County: Wiltshire
Posts: 5

Member car:

147

Reversing light switch 147 53plate

Hey all,

I have had issues with my reversing light. bulb is fine, wiring tested from the bulb to the battery and seems the issue rests with the switch located in the gearbox housing. Before ordering the part i just want to confirm that there maybe isn't anything else i may have missed that someone has already come across?

Oh and the fuse is fine as well

So, a) Has anyone else come across anything else that could cause the problem,
and b) Does anyone know the part number or description just so i don't end up with the incorrect switch?

Any help would be appreciated.

Cheers
Britainboi is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,205
Done this twice on my 156. Easy job with socket on extension bar through battery tray. Battery needs removing but nothing else. Switch is only 15 from europarts but I've found that taking it out and pressing it loads makes it work again. Hopefully the 147 is the same.
dgmayhead is offline  
Status: -
AO Silver Member
 
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,180

Member car:

147 JTDM 16V

I assume you've checked the wires haven't broken where they enter the switch loom connector ? Seems to be a common problem with the reversing light.
Alexie is offline  
(Post Link) post #4 of 5 Old 09-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Aug 2014
Location: United Kingdom
County: Wiltshire
Posts: 5

Member car:

147

Yeah I checked the wiring down to the plug itself. Sounds good. Thanks guys
Britainboi is offline  
Status: -
AO Member
 
Join Date: Jun 2016
County: Hampshire
Posts: 10
Pull the plug from the switch, short its two contacts with a wire, if reverse light comes on, then it's the switch.
On my GT I was able to unplug the connector and do the test without removing anything, bit tight but possible.
sprint2gt is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
147 , 53plate , light , reversing , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome