Airbag lights disappeared on its own? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 07-10-16 Thread Starter
Status: Just got a license
AO Member
 
tishobg's Avatar
 
Join Date: Jun 2016
County: -
Posts: 139
Airbag lights disappeared on its own?

I always had that pesky light on my dashboard. Using MEC i cleared all the faults ,expect one - curtains airbag. Lights was still on. Today I start my car and there is no airbag light. What happened?
Car is Alfa 147 1.9JTD 16v pre-facelift.
tishobg is offline  
Sponsored Links
Advertisement
 
Status: age is only a number ;-)
AO Gold Member
 
rgwm's Avatar
 
Join Date: Aug 2004
Location: Burnley-ish
County: Lancashire
Posts: 9,160
S.H.I.T - happened - Self Healing Italian Technology.......

Probably a bad connection got joggled and cleared itself - on the 147 once a fault condition clears the ECU removes the fault signal - whereas the 156 leaves the fault signal on until the fault is manually cleared. My 147 had a spell recently of the airbag light staying on for a few minutes after initial start - but its cleared itself now.......
rgwm is offline  
Status: -
AO Silver Member
 
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,198
My 156 (2004) clears itself. Earlier cars need Fes and cable.
dgmayhead is offline  
Status: -
AO Member
 
Join Date: May 2016
Location: Bulgaria, Sofia
Posts: 30
Images: 4
Garage
My GT does the same thing from time to time. Jiggling the airbag cables underneath the driver`s or passenger`s seat always fixes the problem (the airbag goes off the next time I turn on the car). But it does tend to pop up from time to time and it is annoying
xen0s is offline  
(Post Link) post #5 of 6 Old 09-10-16 Thread Starter
Status: Just got a license
AO Member
 
tishobg's Avatar
 
Join Date: Jun 2016
County: -
Posts: 139
Italian cars. They realise they have a lot of little things, so they fix some of them for us.
tishobg is offline  
Status: -
AO Member
 
Luca147's Avatar
 
Join Date: Jul 2015
Location: Italy
Posts: 11
Garage
When the airbag light appeared on my dashboard, I cleaned the airbag connections in the boot and underneath the seats with a contacts spray. The airbag light clears itself.
Luca147 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
airbag , disappeared , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome