Fuel Smell and Consumption Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 07-10-16 Thread Starter
Status: -
Newbie
 
Konstantin's Avatar
 
Join Date: Oct 2016
Location: Adelaide
County: Australia
Posts: 2
Garage
Exclamation Fuel Smell and Consumption Problem

I've got a 156 V6 1999 model, and i recently smell petrol in my car when i drive.

Sometimes the fuel injector fault light turns on when i'm driving or after i start my car in the morning.

Also, I have noticed its been chewing too much petrol as well.

One morning my car wouldn't start so i called roadside assistance and he told me the car was choking.

Apparently my engine wasn't burning fuel and it was running on rich.

After that i decided to clean the MAF sensor and the chip inside.

The injection light doesn't turn on anymore. Although, when i drive it goes with high revving.

I also changed the air filter.

My car runs now on 98 octane after the car was choking.

Does anyone know if this is a Fuel filter issue or the Fuel pump?
If so, please tell me where the fuel filter is located in my V6 engine i cant quite find it..

Thank you very much.
If you require more information please tell me.
Konstantin is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,654
My 145 suffered from high fuel consumption there was a smell of petrol when a coolant temperature failed, giving a low temperature reading causing the ECU to overfuel - no injector fault light, though.
Dave Brand is online now  
Status: -
AO Silver Member
 
alfizta's Avatar
 
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,649
Images: 10
check the top of the fuel pump housing in the fuel tank for fuel leak. you will probably need to remove the back seat. but try to get there just by removing the sky hatch first.

Last edited by alfizta; 07-10-16 at 17:01.
alfizta is offline  
Status: -
AO Silver Member
 
alfizta's Avatar
 
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,649
Images: 10
alfizta is offline  
(Post Link) post #5 of 6 Old 09-10-16 Thread Starter
Status: -
Newbie
 
Konstantin's Avatar
 
Join Date: Oct 2016
Location: Adelaide
County: Australia
Posts: 2
Garage
Yes there's a very strong fuel smell in the back seat.
I'll just replace it and see if it fixes it all.
Konstantin is offline  
Status: -
AO Silver Member
 
alfizta's Avatar
 
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,649
Images: 10
if the pump is leaking you will see fuel on top, crossed plastic section.
Attached Images
File Type: jpg 156 JTS fuel pump.JPG (95.7 KB, 2 views)
alfizta is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
consumption or running , fuel , fuel or ignition , idle or throttle , smell or fumes

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome