GT 2.0 JTS Lambda/Fueling Faults - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 28-09-16 Thread Starter
Status: -
Newbie
 
JayWard's Avatar
 
Join Date: Feb 2016
Location: Staffordshire
Posts: 7
GT 2.0 JTS Lambda/Fueling Faults

I was wondering if anyone could shed any light or advice with regards to my faults on my GT 2.0 JTS. I am getting the engine light on and it bogs down on power around 3000 revs. Then feels really sluggish and revs slowly above this rev range. It smells of over fuelling and has lost mpg. It also has a high hydrocarbon rating on an emissions machine.

here are the fault codes (from Delphi):

P0156 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 2) - Intermittent
P1161 - Lambda 2 heater below catalyst - Present
P1172 - Mixture 1 strength (multiplicative) - Intermittent
P1175 - Mixture 2 strength (multiplicative) - Intermittent
P0161 - O2 Sensor Heater Circuit Malfunction (Bank 2 Sensor 2) - Present
P1141 - Lambda 1 heater below catalyst - Present
P0136 - O2 Sensor Circuit Malfunction (Bank 1 Sensor 2) - Present
P0141 - O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2) - Present
P0571 - Cruise Control/Brake Switch A Circuit Malfunction - Intermittent
P0135 - O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1) - Intermittent
P0155 - O2 Sensor Heater Circuit Malfunction (Bank 2 Sensor 1) - Intermittent

As you can see all the faults are related to lambdas or mixture. Surely they wouldn't all fail?

I should of attached a copy of the live data from the vehicle aswell, from idle then to 2.5k around 10 seconds and back to idle around 23 seconds.

Any help appreciated.
Attached Files
File Type: pdf GRAPH.pdf (83.3 KB, 4 views)
JayWard is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,379
When you clear these codes, do they all come back straight away? Has someone sneakily unplugged all your lambdas? Maybe there's a fuse for the lambda heater circuits
sprint_veloce is offline  
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 29,298
The JTS has had issues with poor connections to the Lambda sensors from day one.
They often ended up with the connectors bypassed completely, but the issue was a design fault in the connector which meant the pins weren't properly in the sockets.
David C is offline  
 
Status: :)
AO Member
 
Join Date: Dec 2012
Location: United Kingdom
County: Surrey
Posts: 81
Images: 16
Garage

Member car:

GTV 2.0L JTS

any luck fixing this?
I have the following codes today with rough idle and cutting out,
P0141
P1141
P1151
P0443
P0100
P0135
P0155
P0161
P1161
P1654
P1653

147smith is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
faults , jts , lambda or fueling

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome