air filter box - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 07-09-16 Thread Starter
Status: -
AO Member
 
raggy's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 125
Images: 10
air filter box

hi guys i am currently taking on a few jobs on my 156 selespeed my air filter box 2 of the 3 screws have snapped, normal problem i believe can this be repaired or is it new one tried to get one off ebay no joy should i do away with it and go for something else any suggestions would be appreciated
raggy is offline  
Sponsored Links
Advertisement
 
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,431
Images: 12
Garage
Drill them out but smaller than the original screws and you may fit that the threaded part comes out of the plastic enough to remove the rest. Then araldite the fittings back in and fit new screws.

Of fit self tappers in the drilled holes.

Getting a good unbroken airfilter box now is like finding rocking horse p00 ...

Don't fit a cone filter .. they upset the car's running ..
gazza82 is offline  
(Post Link) post #3 of 7 Old 09-09-16 Thread Starter
Status: -
AO Member
 
raggy's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 125
Images: 10
Quote:
Originally Posted by gazza82 View Post
Drill them out but smaller than the original screws and you may fit that the threaded part comes out of the plastic enough to remove the rest. Then araldite the fittings back in and fit new screws.

Of fit self tappers in the drilled holes.

Getting a good unbroken airfilter box now is like finding rocking horse p00 ...

Don't fit a cone filter .. they upset the car's running ..
thanks mate, what is the v6 modification i have herd about is that different and better do you no.
raggy is offline  
 
Status: -
AO Member
 
Join Date: Aug 2016
Location: Boness
County: Fife
Posts: 15

Member car:

156 1.9it'd 8v

I had similar issue earlier this week, I discovered two of the three screws were rusted solid, and to top that off the fixing lug holes on the box lid had been forced and were broken which meant the lid was not actually fixed properly and must have been causing a massive leak.
Really through sheer determination and lots of grunting I managed to remove the two stubborn rusty screws using some small monkey renches and remitted new screws with some washers to hold the lid down tight.
I had also changed the oil and filter and fuel filter too along with upper turbo hose.
Improvement a cross the board was immediately noticed.
Next step is to try nd sort the rumbling alternator pulley lol
alfamonky is offline  
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 29,237
Quote:
Originally Posted by raggy View Post
thanks mate, what is the v6 modification i have herd about is that different and better do you no.
That is the intake pipe that fits into the side of the air filter housing.
The EU TS have a big silencer box on the side, you can remove that and fit the simple pipe from the V6/JTD instead.
Outside the EU the TS didn't have the silencer and had a longer pipe instead. Won't be easy to get one of those now though. The Italian Police versions had the long intake pipe too.


So it still needs a good air filter housing.
David C is online now  
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,431
Images: 12
Garage
This is what they put on the air filter box before the filter and hidden away in the inner wing! If you look on my greenserpent website under how-tos, there's a PDF with pics of the V6 pipe in it's place. Or you can use the GTA pipe.
Attached Images
File Type: jpg OriginalAirBox.jpg (13.5 KB, 31 views)
gazza82 is offline  
(Post Link) post #7 of 7 Old 01-10-16 Thread Starter
Status: -
AO Member
 
raggy's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 125
Images: 10
thanks guys got all of it off tried to drill out the lugs came out so will take them to engineering company and get them to drill and re thread them then i will stick them back in hopefull
raggy is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
air , box , filter

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome