GT Crank sensor replacement - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-09-16 Thread Starter
Status: -
Join Date: Sep 2016
Location: Pretoria
County: -South Africa
Posts: 1

Member car:


Question GT Crank sensor replacement

HI guys,
I have a 2006 1.9jtd, and after lots of searching is seems my crank sensor is the culprit.
I have the following symptoms:
car cuts out when it it gets hot, after a 30 km trip or so, if you wait a while for it to cool down , it will start up again, but it runs rough.
Seeing that it may be the crank sensor, and needs to be replaced, a job I can do myself, should the cam belt also be replaced?
The car has only 95 000 km on it?

Thanking you in advance.
101lee is offline  
Sponsored Links
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,497
if you don't know when the last cambelt waa done, then replace it!!!

not so bad on the dervs admittedly as they only damage the rockers most of the time but never the less...

re the CPS

good luck
joeymannero is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crank , replacement , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome